summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2017-09-04 12:24:41 +0200
committerDaniel Stenberg <daniel@haxx.se>2017-09-06 08:43:36 +0200
commitd1da545a6881dbeafff86077f696f0dc22d3fc81 (patch)
tree3c70de0f8382396ac290148eeff6c46d010d605e /configure.ac
parent61825be02ba3d86dcf6ce8c3854d31d212796094 (diff)
downloadcurl-d1da545a6881dbeafff86077f696f0dc22d3fc81.tar.gz
configure: remove --enable-soname-bump and SONAME_BUMP
Back in 2008, (and commit 3f3d6ebe665f3) we changed the logic in how we determine the native type for `curl_off_t`. To really make sure we didn't break ABI without bumping SONAME, we introduced logic that attempted to detect that it would use a different size and thus not be compatible. We also provided a manual switch that allowed users to tell configure to bump SONAME by force. Today, we know of no one who ever got a SONAME bump auto-detected and we don't know of anyone who's using the manual bump feature. The auto- detection is also no longer working since we introduced defining curl_off_t in system.h (7.55.0). Finally, this bumping logic is not present in the cmake build. Closes #1861
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac33
1 files changed, 0 insertions, 33 deletions
diff --git a/configure.ac b/configure.ac
index 93f1fa007..aa6fd0a53 100755
--- a/configure.ac
+++ b/configure.ac
@@ -3259,8 +3259,6 @@ AC_CHECK_SIZEOF(curl_off_t, unused , [
])
CPPFLAGS=$o
-soname_bump=no
-
AC_CHECK_TYPE(long long,
[AC_DEFINE(HAVE_LONGLONG, 1,
[Define to 1 if the compiler supports the 'long long' data type.])]
@@ -3738,26 +3736,6 @@ dnl hiding of library internal symbols
dnl
CURL_CONFIGURE_SYMBOL_HIDING
-dnl ************************************************************
-dnl enforce SONAME bump
-dnl
-
-AC_MSG_CHECKING([whether to enforce SONAME bump])
-AC_ARG_ENABLE(soname-bump,
-AC_HELP_STRING([--enable-soname-bump],[Enable enforced SONAME bump])
-AC_HELP_STRING([--disable-soname-bump],[Disable enforced SONAME bump]),
-[ case "$enableval" in
- yes) AC_MSG_RESULT(yes)
- soname_bump=yes
- ;;
- *)
- AC_MSG_RESULT(no)
- ;;
- esac ],
- AC_MSG_RESULT($soname_bump)
-)
-AM_CONDITIONAL(SONAME_BUMP, test x$soname_bump = xyes)
-
dnl
dnl All the library dependencies put into $LIB apply to libcurl only.
dnl
@@ -4045,14 +4023,3 @@ AC_MSG_NOTICE([Configured to build curl/libcurl:
HTTP2 support: ${curl_h2_msg}
Protocols: ${SUPPORT_PROTOCOLS}
])
-
-if test "x$soname_bump" = "xyes"; then
-
-cat <<EOM
- SONAME bump: yes - WARNING: this library will be built with the SONAME
- number bumped due to (a detected) ABI breakage.
- See lib/README.curl_off_t for details on this.
-EOM
-
-fi
-