summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorFutaura <oliver@futaura.co.uk>2022-08-07 17:15:16 +0100
committerDaniel Stenberg <daniel@haxx.se>2022-08-08 15:49:28 +0200
commitc6631e827d208f231f610309508ec9a391297fb5 (patch)
tree2babf54a5bdea3180ac04f9aa0f11a7d464c0916 /configure.ac
parent80e9eef737b19ccf2f57d1e8988bf1874ad36bbc (diff)
downloadcurl-c6631e827d208f231f610309508ec9a391297fb5.tar.gz
configure: fixup bsdsocket detection code for AmigaOS 4.x
The code that detects bsdsocket.library for AmigaOS did not work for AmigaOS 4.x. This has been fixed and also cleaned up a little to reduce duplication. Wasn't technically necessary before, but is required when building with AmiSSL instead of OpenSSL. Closes #9268
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6f19a5f4c..6cd2b132c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1151,8 +1151,13 @@ then
AC_MSG_CHECKING([for gethostbyname for AmigaOS bsdsocket.library])
AC_LINK_IFELSE([
AC_LANG_PROGRAM([[
+ #define __USE_INLINE__
#include <proto/bsdsocket.h>
+ #ifdef __amigaos4__
+ struct SocketIFace *ISocket = NULL;
+ #else
struct Library *SocketBase = NULL;
+ #endif
]],[[
gethostbyname("www.dummysite.com");
]])