summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2022-09-11 00:10:26 +0200
committerDaniel Stenberg <daniel@haxx.se>2022-09-11 11:18:38 +0200
commitae4d1437f1653b2d2529bf1f77672ce708025cf6 (patch)
tree30071dffe946ed904041af36595e801e9c9f4d0a /configure.ac
parentb62d236f7d267e5af9d8a7551d16876733fe2238 (diff)
downloadcurl-ae4d1437f1653b2d2529bf1f77672ce708025cf6.tar.gz
configure: correct the wording when checking grep -E
The check first checks that grep -E works, and only as a fallback tries to find and use egrep. egrep is deprecated. This change only corrects the output wording, not the checks themselves. Closes #9471
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 5 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 17c0a7cdc..5cda91652 100644
--- a/configure.ac
+++ b/configure.ac
@@ -85,21 +85,22 @@ if test -z "$GREP"; then
fi
AC_SUBST([GREP])
-dnl EGREP is mandatory for configure process and libtool.
+dnl 'grep -E' is mandatory for configure process and libtool.
dnl Set it now, allowing it to be changed later.
if test -z "$EGREP"; then
dnl allow it to be overridden
+ AC_MSG_CHECKING([that grep -E works])
if echo a | ($GREP -E '(a|b)') >/dev/null 2>&1; then
- AC_MSG_CHECKING([for egrep])
EGREP="$GREP -E"
- AC_MSG_RESULT([$EGREP])
+ AC_MSG_RESULT([yes])
else
+ AC_MSG_RESULT([no])
AC_PATH_PROG([EGREP], [egrep], [not_found],
[$PATH:/usr/bin:/usr/local/bin])
fi
fi
if test -z "$EGREP" || test "$EGREP" = "not_found"; then
- AC_MSG_ERROR([egrep not found in PATH. Cannot continue without egrep.])
+ AC_MSG_ERROR([grep -E is not working and is egrep not found in PATH. Cannot continue.])
fi
AC_SUBST([EGREP])