summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2022-08-11 09:07:02 +0200
committerDaniel Stenberg <daniel@haxx.se>2022-08-11 09:07:02 +0200
commit9e11c2791fb960758ad46b53c80fa37029c5501b (patch)
tree5ad829d47dabddbac8532cf9c7d71c80c6e14e3f /configure.ac
parentd6010c210635cadcfd6c91ed89cbbe4b091b628a (diff)
downloadcurl-9e11c2791fb960758ad46b53c80fa37029c5501b.tar.gz
configure: introduce CURL_SIZEOF
This is a rewrite of the previously used GPLv3+exception licensed file. With this change, there is no more reference to GPL so we can remove that from LICENSES/. Ref: #9220 Closes #9291
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 7 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 6cd2b132c..44bf42b9d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3290,16 +3290,16 @@ AC_TYPE_SIZE_T
CURL_CHECK_STRUCT_TIMEVAL
CURL_VERIFY_RUNTIMELIBS
-AX_COMPILE_CHECK_SIZEOF(size_t)
-AX_COMPILE_CHECK_SIZEOF(long)
-AX_COMPILE_CHECK_SIZEOF(int)
-AX_COMPILE_CHECK_SIZEOF(short)
-AX_COMPILE_CHECK_SIZEOF(time_t)
-AX_COMPILE_CHECK_SIZEOF(off_t)
+CURL_SIZEOF(size_t)
+CURL_SIZEOF(long)
+CURL_SIZEOF(int)
+CURL_SIZEOF(short)
+CURL_SIZEOF(time_t)
+CURL_SIZEOF(off_t)
o=$CPPFLAGS
CPPFLAGS="-I$srcdir/include $CPPFLAGS"
-AX_COMPILE_CHECK_SIZEOF(curl_off_t, [
+CURL_SIZEOF(curl_off_t, [
#include <curl/system.h>
])
CPPFLAGS=$o