summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Zitzmann <nickzman@gmail.com>2017-08-16 12:24:39 -0500
committerGitHub <noreply@github.com>2017-08-16 12:24:39 -0500
commit870d849d48a26b8eeb0d4bb1f4655367a4a191ca (patch)
tree48415a008b75a845d0dc8f03c71b66fa4e59d299 /configure.ac
parentca9630f12843f0bb0baa3ae78491e07431ccf5de (diff)
downloadcurl-870d849d48a26b8eeb0d4bb1f4655367a4a191ca.tar.gz
configure: check for __builtin_available() availability (#1788)
This change does two things: 1. It un-breaks the build in Xcode 9.0. (Xcode 9.0 is currently failing trying to compile connectx() in lib/connect.c.) 2. It finally weak-links the connectx() function, and falls back on connect() when run on older operating systems.
Diffstat (limited to 'configure.ac')
-rwxr-xr-x[-rw-r--r--]configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index edebfc77b..605abc3fd 100644..100755
--- a/configure.ac
+++ b/configure.ac
@@ -354,6 +354,7 @@ esac
CURL_CHECK_WIN32_LARGEFILE
CURL_MAC_CFLAGS
+CURL_SUPPORTS_BUILTIN_AVAILABLE
dnl ************************************************************
dnl switch off particular protocols