summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2004-11-11 14:41:37 +0000
committerDaniel Stenberg <daniel@haxx.se>2004-11-11 14:41:37 +0000
commit7bb6d76d14b7fa5396b88bfcf8414a6514f9115e (patch)
tree492a02c251de02504d371fd2bffc15e019b3ebc7 /configure.ac
parent2467f814a81f614301c257ab0afb1db29f3ec4f7 (diff)
downloadcurl-7bb6d76d14b7fa5396b88bfcf8414a6514f9115e.tar.gz
When libidn is detected without explicitly told to, we provide -L/lib and
-I/include options. Not anymore.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 13 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index 78e80a5e7..473e4341d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -968,16 +968,19 @@ case "$LIBIDN" in
idn=""
dnl if there is a given path, check that FIRST
- if test "x$LIBIDN" != "xyes"; then
- oldLDFLAGS=$LDFLAGS
- oldCPPFLAGS=$CPPFLAGS
- LDFLAGS="$LDFLAGS -L$LIBIDN/lib"
- CPPFLAGS="$CPPFLAGS -I$LIBIDN/include"
- idn="yes"
- AC_CHECK_LIB(idn, idna_to_ascii_4i, ,
- idn=""
- LDFLAGS=$oldLDFLAGS
- CPPFLAGS=$oldCPPFLAGS)
+ if test -n "$LIBIDN"; then
+ if test "x$LIBIDN" != "xyes"; then
+ AC_MSG_WARN([moo moo $LIBIDN])
+ oldLDFLAGS=$LDFLAGS
+ oldCPPFLAGS=$CPPFLAGS
+ LDFLAGS="$LDFLAGS -L$LIBIDN/lib"
+ CPPFLAGS="$CPPFLAGS -I$LIBIDN/include"
+ idn="yes"
+ AC_CHECK_LIB(idn, idna_to_ascii_4i, ,
+ idn=""
+ LDFLAGS=$oldLDFLAGS
+ CPPFLAGS=$oldCPPFLAGS)
+ fi
fi
if test "x$idn" != "xyes"; then