summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGunter Knauf <gk@gknw.de>2008-12-27 04:30:36 +0000
committerGunter Knauf <gk@gknw.de>2008-12-27 04:30:36 +0000
commit6efde612278f16bc4e496ef4c62e38426df095a4 (patch)
treefb6b21d468099873bf21f2752419fa96553750f9 /configure.ac
parent1c48124db486fdb78a7b264d5b1850dcf0821d2f (diff)
downloadcurl-6efde612278f16bc4e496ef4c62e38426df095a4.tar.gz
added check for sin6_scope_id member in struct sockaddr_in6.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f98bded54..92b295ac4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -818,6 +818,21 @@ if test "$ipv6" = "yes"; then
curl_ipv6_msg="enabled"
fi
+# Check if struct sockaddr_in6 have sin6_scope_id member
+if test "$ipv6" = yes; then
+ AC_MSG_CHECKING([if struct sockaddr_in6 has sin6_scope_id member])
+ AC_TRY_COMPILE([
+#include <sys/types.h>
+#include <netinet/in.h>] ,
+ struct sockaddr_in6 s; s.sin6_scope_id = 0; , have_sin6_scope_id=yes)
+ if test "$have_sin6_scope_id" = yes; then
+ AC_MSG_RESULT([yes])
+ AC_DEFINE(HAVE_SIN6_SCOPE_ID, 1, [Define to 1 if struct sockaddr_in6 has the sin6_scope_id member])
+ else
+ AC_MSG_RESULT([no])
+ fi
+fi
+
dnl **********************************************************************
dnl Check if the operating system allows programs to write to their own argv[]
dnl **********************************************************************