summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2018-06-14 16:52:43 +0200
committerDaniel Stenberg <daniel@haxx.se>2018-06-14 23:08:04 +0200
commit351dabbf3dfe1370045a29aa6dba3e0a3686eaeb (patch)
treef7651c1430a92f0974e1a3f65076207ec9d05ce3 /configure.ac
parented224f23d5bebf3f2b64d28ca4452b401a8ddf0a (diff)
downloadcurl-351dabbf3dfe1370045a29aa6dba3e0a3686eaeb.tar.gz
configure: enhance ability to detect/build with static openssl
Fix the -ldl and -ldl + -lpthread checks for OpenSSL, necessary for building with static libs without pkg-config. Reported-by: Marcel Raad Fixes #2199 Closes #2659
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index a9fd3d103..f38e1c0ce 100755
--- a/configure.ac
+++ b/configure.ac
@@ -1657,7 +1657,7 @@ if test -z "$ssl_backends" -o "x$OPT_SSL" != xno &&
dnl still no, but what about with -ldl?
AC_MSG_CHECKING([OpenSSL linking with -ldl])
- LIBS="$LIBS -ldl"
+ LIBS="$LIBS -ldl -lcrypto"
AC_TRY_LINK(
[
#include <openssl/err.h>
@@ -1674,7 +1674,7 @@ if test -z "$ssl_backends" -o "x$OPT_SSL" != xno &&
dnl ok, so what about bouth -ldl and -lpthread?
AC_MSG_CHECKING([OpenSSL linking with -ldl and -lpthread])
- LIBS="$LIBS -lpthread"
+ LIBS="$CLEANLIBS -ldl -lpthread -lcrypto"
AC_TRY_LINK(
[
#include <openssl/err.h>