summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Dymond <cmeister2@gmail.com>2017-08-27 15:57:05 +0100
committerDaniel Stenberg <daniel@haxx.se>2017-09-01 11:22:51 +0200
commitefeb4a317616b0437a26277945bd300eaffe96d7 (patch)
tree86f46482f6f9a4eb98fcad25eeb06ea0027b01dc /Makefile.am
parent222e65fd783bec974b99345e0d618d4e627304de (diff)
downloadcurl-efeb4a317616b0437a26277945bd300eaffe96d7.tar.gz
ossfuzz: moving towards the ideal integration
- Start with the basic code from the ossfuzz project. - Rewrite fuzz corpora to be binary files full of Type-Length-Value data, and write a glue layer in the fuzzing function to convert corpora into CURL options. - Have supporting functions to generate corpora from existing tests - Integrate with Makefile.am
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index ab8f11cbc..e517ba56e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -210,6 +210,9 @@ test-am:
endif
+fuzzer:
+ @(cd tests/fuzz; $(MAKE) all)
+
examples:
@(cd docs/examples; $(MAKE) check)