summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2005-03-11 00:44:32 +0000
committerDaniel Stenberg <daniel@haxx.se>2005-03-11 00:44:32 +0000
commitc4ce9ac4de5eeb924c9f5fd98bc1c6d58481db43 (patch)
tree9044d4190157271a7f662e9fabd00a5e272e5387 /Makefile.am
parent0e4e28fddae4163ffe6e10432978eab946e0ec6c (diff)
downloadcurl-c4ce9ac4de5eeb924c9f5fd98bc1c6d58481db43.tar.gz
Add an alert already here if 'make test' is attempted for a cross-compile
since there's no use building the whole test suite first and _then_ tell it doesn't work anyway...
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index e759fe3af..71e530277 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -48,6 +48,15 @@ pdf:
check: test
+if CROSSCOMPILING
+test-full: test
+test-torture: test
+
+test:
+ @echo "NOTICE: we can't run the tests when cross-compiling!"
+
+else
+
test:
@(cd tests; $(MAKE) all quiet-test)
@@ -57,6 +66,8 @@ test-full:
test-torture:
@(cd tests; $(MAKE) all torture-test)
+endif
+
#
# Build source and binary rpms. For rpm-3.0 and above, the ~/.rpmmacros
# must contain the following line: