summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2018-10-23 00:33:27 +0200
committerDaniel Stenberg <daniel@haxx.se>2018-10-27 15:59:38 +0200
commitbe208141915f18d4ffae66078303fe15d717c8b5 (patch)
treed27562b8d9c0550dff39094cb1577ac72ffad3f8 /Makefile.am
parent803496fa10822cb3fa15e51d3a189e8a948d33a4 (diff)
downloadcurl-be208141915f18d4ffae66078303fe15d717c8b5.tar.gz
Makefile: add 'tidy' target that runs clang-tidy
Available in the root, src and lib dirs. Closes #3163
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index dd93a383e..debec9aa3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -5,7 +5,7 @@
# | (__| |_| | _ <| |___
# \___|\___/|_| \_\_____|
#
-# Copyright (C) 1998 - 2017, Daniel Stenberg, <daniel@haxx.se>, et al.
+# Copyright (C) 1998 - 2018, Daniel Stenberg, <daniel@haxx.se>, et al.
#
# This software is licensed as described in the file COPYING, which
# you should have received as part of this distribution. The terms
@@ -642,3 +642,7 @@ function gen_element(type, dir, file)\
-v src_x_srcs="$$sorted_src_x_srcs" \
-v src_x_hdrs="$$sorted_src_x_hdrs" \
"$$awk_code" $(srcdir)/$(VC15_SRCTMPL) > $(VC15_SRCVCXPROJ) || { exit 1; };)
+
+tidy:
+ (cd src && $(MAKE) tidy)
+ (cd lib && $(MAKE) tidy)