summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorViktor Szakats <commit@vsz.me>2023-04-16 22:28:25 +0000
committerViktor Szakats <commit@vsz.me>2023-04-16 22:28:25 +0000
commit9c543de0ecf14880c3324d3d24591fb695dd1917 (patch)
tree1e41ac4e14cabc63d0fa4fe35cdf8c1be7e7a4bd /Makefile.am
parent15a361892d43828b01cf245c70ebb98f21a8dc83 (diff)
downloadcurl-9c543de0ecf14880c3324d3d24591fb695dd1917.tar.gz
cmake: speed up and extend picky clang/gcc options
Extend existing picky compiler options with ones missing compared to autotools builds. Also sync options between clang and gcc. Redesign the way we enable these options to avoid the slow option detection almost completely. This reduces the number of detections from 35 to zero for clang and 3 for gcc, even after adding a bunch of new options. clang 3.0 (2011-11-29) and gcc 2.95 (1999-07-31) now required. Also show enabled picky options. Ref: https://github.com/libssh2/libssh2/pull/952 Reviewed-by: Daniel Stenberg Closes #10973
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index ac1ecd994..f25e4e2f0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -49,6 +49,7 @@ CMAKE_DIST = \
CMake/FindZstd.cmake \
CMake/Macros.cmake \
CMake/OtherTests.cmake \
+ CMake/PickyWarnings.cmake \
CMake/Platforms/WindowsCache.cmake \
CMake/Utilities.cmake \
CMakeLists.txt