summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaniel Shahaf <d.s@daniel.shahaf.name>2015-11-19 22:23:11 +0000
committerDaniel Stenberg <daniel@haxx.se>2015-11-20 00:25:42 +0100
commit80562083da0b51d594fe9765b079eefdd3ba87b7 (patch)
treec994eef82828c935b85e9550befcbe4421f19e03 /Makefile.am
parentff8d352ae944d1f7f5941e42a2dd4cc8d23df5d0 (diff)
downloadcurl-80562083da0b51d594fe9765b079eefdd3ba87b7.tar.gz
build: Fix theoretical infinite loops
Add error-checking to 'cd' in a few cases where omitting the checks might result in an infinite loop. Closes #535
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 5f1c881bc..bdcf4b5f3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -160,10 +160,10 @@ dist-hook:
done)
html:
- cd docs; make html
+ cd docs && make html
pdf:
- cd docs; make pdf
+ cd docs && make pdf
check: test examples check-docs