summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPeter Wu <peter@lekensteyn.nl>2020-05-08 23:13:46 +0200
committerDaniel Stenberg <daniel@haxx.se>2020-05-10 23:36:41 +0200
commit5bfc874a359c229adf82ab7495c8f7d28dea992e (patch)
tree23c8b65ee4cc240b828390b60a04ee34276aefbb /Makefile.am
parent000f72169092ffca83e571d16ec840c7b840f756 (diff)
downloadcurl-5bfc874a359c229adf82ab7495c8f7d28dea992e.tar.gz
CMake: add HTTP/3 support (ngtcp2+nghttp3, quiche)
Add three new CMake Find modules (using the curl license, but I grant others the right to apply the CMake BSD license instead). This CMake config is simpler than the autotools one because it assumes ngtcp2 and nghttp3 to be used together. Another difference is that this CMake config checks whether QUIC is actually supported by the TLS library (patched OpenSSL or boringssl) since this can be a common configuration mistake that could result in build errors later. Unlike autotools, CMake does not warn you that the features are experimental. The user is supposed to already know that and read the documentation. It requires a very special build environment anyway. Tested with ngtcp2+OpenSSL+nghttp3 and quiche+boringssl, both built from current git master. Use `LD_DEBUG=files src/curl |& grep need` to figure out which features (libldap-2.4, libssh2) to disable due to conflicts with boringssl. Closes #5359
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 2f7098033..b9632770d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -36,6 +36,9 @@ CMAKE_DIST = \
CMake/FindLibSSH2.cmake \
CMake/FindMbedTLS.cmake \
CMake/FindNGHTTP2.cmake \
+ CMake/FindNGHTTP3.cmake \
+ CMake/FindNGTCP2.cmake \
+ CMake/FindQUICHE.cmake \
CMake/FindWolfSSL.cmake \
CMake/Macros.cmake \
CMake/OtherTests.cmake \