summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorChristian Weisgerber via curl-library <curl-library@lists.haxx.se>2022-05-19 15:45:07 +0200
committerDaniel Stenberg <daniel@haxx.se>2022-05-19 15:45:26 +0200
commit46f11a4cef48f5ba95f7757e4e4ab96fa43e0444 (patch)
treeefb7183b746ac3d8221a7e6584db2600af518e32 /Makefile.am
parentdfa84a0450ca4bc08ccaebb8dfffb23735b281ef (diff)
downloadcurl-46f11a4cef48f5ba95f7757e4e4ab96fa43e0444.tar.gz
Makefile.am: fix portability issues
Commit a04f0b961333e1a19848d073d8c7db9c20b2a371 made me notice that there is a portability issue in curl's top-level Makefile.am. $< can only be used in rules that deal with .SUFFIXES. Its use for general prerequisites is a GNU make extension. $< could be replaced by $?, but I think in an autotools context, something like this is better: Bug: https://curl.se/mail/lib-2022-05/0024.html Closes #8861
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index f91c706fe..d32e787c3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -279,13 +279,13 @@ uninstall-hook:
(cd docs && $(MAKE) uninstall)
(cd docs/libcurl && $(MAKE) uninstall)
-ca-bundle: scripts/mk-ca-bundle.pl
+ca-bundle: $(srcdir)/scripts/mk-ca-bundle.pl
@echo "generating a fresh ca-bundle.crt"
- @perl $< -b -l -u lib/ca-bundle.crt
+ @perl $(srcdir)/scripts/mk-ca-bundle.pl -b -l -u lib/ca-bundle.crt
-ca-firefox: scripts/firefox-db2pem.sh
+ca-firefox: $(srcdir)/scripts/firefox-db2pem.sh
@echo "generating a fresh ca-bundle.crt"
- $< lib/ca-bundle.crt
+ $(srcdir)/scripts/firefox-db2pem.sh lib/ca-bundle.crt
checksrc:
(cd lib && $(MAKE) checksrc)