summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2020-03-12 17:18:40 +0100
committerDaniel Stenberg <daniel@haxx.se>2020-03-16 22:56:50 +0100
commit37a05418820dfcdb68bc0d535e76e63945b45917 (patch)
tree332700ffeb5c378e8768309a71a7d52f3f0064a1 /Makefile.am
parent95c36fff75883ace6e8e7a89b94362de2dd1857f (diff)
downloadcurl-37a05418820dfcdb68bc0d535e76e63945b45917.tar.gz
cmake: add support for building with wolfSSLbagder/cmake-wolfssl
My working build cmdline: $ cmake -DCMAKE_PREFIX_PATH=$HOME/build-wolfssl -DCMAKE_USE_WOLFSSL=ON . Assisted-by: Brad King Closes #5095
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am28
1 files changed, 19 insertions, 9 deletions
diff --git a/Makefile.am b/Makefile.am
index cb679a380..5eacfa846 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -5,7 +5,7 @@
# | (__| |_| | _ <| |___
# \___|\___/|_| \_\_____|
#
-# Copyright (C) 1998 - 2018, Daniel Stenberg, <daniel@haxx.se>, et al.
+# Copyright (C) 1998 - 2020, Daniel Stenberg, <daniel@haxx.se>, et al.
#
# This software is licensed as described in the file COPYING, which
# you should have received as part of this distribution. The terms
@@ -24,14 +24,24 @@ AUTOMAKE_OPTIONS = foreign
ACLOCAL_AMFLAGS = -I m4
-CMAKE_DIST = CMakeLists.txt CMake/CMakeConfigurableFile.in \
- CMake/CurlTests.c CMake/FindGSS.cmake CMake/OtherTests.cmake \
- CMake/Platforms/WindowsCache.cmake CMake/Utilities.cmake \
- CMake/Macros.cmake \
- CMake/CurlSymbolHiding.cmake CMake/FindCARES.cmake \
- CMake/FindLibSSH2.cmake CMake/FindNGHTTP2.cmake \
- CMake/FindMbedTLS.cmake CMake/FindBearSSL.cmake \
- CMake/cmake_uninstall.cmake.in CMake/curl-config.cmake.in
+CMAKE_DIST = \
+ CMake/cmake_uninstall.cmake.in \
+ CMake/CMakeConfigurableFile.in \
+ CMake/curl-config.cmake.in \
+ CMake/CurlSymbolHiding.cmake \
+ CMake/CurlTests.c \
+ CMake/FindBearSSL.cmake \
+ CMake/FindCARES.cmake \
+ CMake/FindGSS.cmake \
+ CMake/FindLibSSH2.cmake \
+ CMake/FindMbedTLS.cmake \
+ CMake/FindNGHTTP2.cmake \
+ CMake/FindWolfSSL.cmake \
+ CMake/Macros.cmake \
+ CMake/OtherTests.cmake \
+ CMake/Platforms/WindowsCache.cmake \
+ CMake/Utilities.cmake \
+ CMakeLists.txt
VC6_LIBTMPL = projects/Windows/VC6/lib/libcurl.tmpl
VC6_LIBDSP = projects/Windows/VC6/lib/libcurl.dsp.dist