summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2017-03-22 10:48:20 +0100
committerDaniel Stenberg <daniel@haxx.se>2017-03-22 10:48:20 +0100
commit207f588987855e4ab8bc836c7f45d5323f1f69e5 (patch)
tree265c3a571ee9a5c3bdc4f73329e0ee6dbfec2ea7 /Makefile.am
parent96d6942b2d55ea617e0c9d204f97e4aabca9ad27 (diff)
downloadcurl-207f588987855e4ab8bc836c7f45d5323f1f69e5.tar.gz
make: introduce 'test-nonflaky' target
Running this in the root build dir will invoke the test suite to only run tests not marked as 'flaky'.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 1507a841e..fcc5606b0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -193,6 +193,9 @@ test:
test-full:
@(cd tests; $(MAKE) all full-test)
+test-nonflaky:
+ @(cd tests; $(MAKE) all nonflaky-test)
+
test-torture:
@(cd tests; $(MAKE) all torture-test)