summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2017-06-13 22:03:37 +0200
committerDaniel Stenberg <daniel@haxx.se>2017-06-14 15:44:37 +0100
commit11c2fb04467520b82f2251629710e6d4a0798700 (patch)
tree8cd6b593a1e0f2ad0f15a098f8131afb033eab60 /Makefile.am
parent73a2fcea0b4adea6ba342cd7ed1149782c214ae3 (diff)
downloadcurl-11c2fb04467520b82f2251629710e6d4a0798700.tar.gz
dist: make the hugehelp.c not get regenerated unnecessarily
The maketgz script now makes sure the generated hugehelp.c file in the tarball is newer than the generated curl.1 man page, so that it doesn't have to get unnecessarily rebuilt first thing in a typical build. It thus also removes the need for perl to build off a plain release tarball. Fixes #1565
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 5ebc7ee98..dc66067cf 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -170,7 +170,7 @@ dist-hook:
(distit=`find $(srcdir) -name "*.dist" | grep -v ./ares/`; \
for file in $$distit; do \
strip=`echo $$file | sed -e s/^$(srcdir)// -e s/\.dist//`; \
- cp $$file $(distdir)$$strip; \
+ cp -p $$file $(distdir)$$strip; \
done)
html: