summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMuhammad Herdiansyah <herdiansyah@netc.eu>2020-03-11 06:51:05 +0700
committerDaniel Stenberg <daniel@haxx.se>2020-03-11 10:15:06 +0100
commit0cc66ff5a43a7e24bdc225d7d3b2cd9a1b0259b9 (patch)
tree8b0d40afddd005c1f8678b795d2cbffdbe9973d0 /Makefile.am
parent27ea8fc2faa4e4753a9cff0a7f48d1dba68013d6 (diff)
downloadcurl-0cc66ff5a43a7e24bdc225d7d3b2cd9a1b0259b9.tar.gz
Makefile: run the cd commands in a subshell
In bmake, if the directory is changed (with cd or anything else), bmake won't return to the "root directory" on the next command (in the same Makefile rule). This commit runs the cd command in a subshell so it would work in bmake. Closes #5073
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am22
1 files changed, 11 insertions, 11 deletions
diff --git a/Makefile.am b/Makefile.am
index 1e9ecd8c4..cb679a380 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -289,15 +289,15 @@ cygwinbin:
# We extend the standard install with a custom hook:
install-data-hook:
- cd include && $(MAKE) install
- cd docs && $(MAKE) install
- cd docs/libcurl && $(MAKE) install
+ (cd include && $(MAKE) install)
+ (cd docs && $(MAKE) install)
+ (cd docs/libcurl && $(MAKE) install)
# We extend the standard uninstall with a custom hook:
uninstall-hook:
- cd include && $(MAKE) uninstall
- cd docs && $(MAKE) uninstall
- cd docs/libcurl && $(MAKE) uninstall
+ (cd include && $(MAKE) uninstall)
+ (cd docs && $(MAKE) uninstall)
+ (cd docs/libcurl && $(MAKE) uninstall)
ca-bundle: lib/mk-ca-bundle.pl
@echo "generating a fresh ca-bundle.crt"
@@ -308,11 +308,11 @@ ca-firefox: lib/firefox-db2pem.sh
./lib/firefox-db2pem.sh lib/ca-bundle.crt
checksrc:
- cd lib && $(MAKE) checksrc
- cd src && $(MAKE) checksrc
- cd tests && $(MAKE) checksrc
- cd include/curl && $(MAKE) checksrc
- cd docs/examples && $(MAKE) checksrc
+ (cd lib && $(MAKE) checksrc)
+ (cd src && $(MAKE) checksrc)
+ (cd tests && $(MAKE) checksrc)
+ (cd include/curl && $(MAKE) checksrc)
+ (cd docs/examples && $(MAKE) checksrc)
.PHONY: vc-ide