summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2023-01-02 23:25:15 +0100
committerDaniel Stenberg <daniel@haxx.se>2023-01-03 08:51:51 +0100
commitf86894a38c94a717389cbea56711df94c75a483c (patch)
tree9ef2c2fad6302b730761ef7c7f9f8a13616f1c24 /CMakeLists.txt
parent7baff01fd6ef21c06f003ecd6fc4370d762d4691 (diff)
downloadcurl-f86894a38c94a717389cbea56711df94c75a483c.tar.gz
cmake: check for sendmsg
Used by ngtcp2 Closes #10211
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 982cf6729..e2b786bc8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1048,6 +1048,7 @@ check_symbol_exists(socket "${CURL_INCLUDES}" HAVE_SOCKET)
check_symbol_exists(socketpair "${CURL_INCLUDES}" HAVE_SOCKETPAIR)
check_symbol_exists(recv "${CURL_INCLUDES}" HAVE_RECV)
check_symbol_exists(send "${CURL_INCLUDES}" HAVE_SEND)
+check_symbol_exists(sendmsg "${CURL_INCLUDES}" HAVE_SENDMSG)
check_symbol_exists(select "${CURL_INCLUDES}" HAVE_SELECT)
check_symbol_exists(strdup "${CURL_INCLUDES}" HAVE_STRDUP)
check_symbol_exists(strtok_r "${CURL_INCLUDES}" HAVE_STRTOK_R)