summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorALittleDruid <297957399@qq.com>2023-01-28 20:23:25 +0800
committerJay Satiro <raysatiro@yahoo.com>2023-02-18 19:00:24 -0500
commitf5a88f2978e4a8d6fe15de39497f009a81a52bf6 (patch)
tree4bbb3805a420157fb0c987c14b2e137870dbbf2a /CMakeLists.txt
parentbf54c9382fb4f26a6f6dd1e77fb2d462e3dd8d04 (diff)
downloadcurl-f5a88f2978e4a8d6fe15de39497f009a81a52bf6.tar.gz
cmake: fix Windows check for CryptAcquireContext
Check for CryptAcquireContext in windows.h and wincrypt.h only, since otherwise this check may fail due to third party headers not found. Closes https://github.com/curl/curl/pull/10353
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cf40054f9..eb998fb0f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1277,7 +1277,7 @@ if(WIN32)
# Check if crypto functions in wincrypt.h are actually available
if(HAVE_WINCRYPT_H)
- check_symbol_exists(CryptAcquireContext "${CURL_INCLUDES}" USE_WINCRYPT)
+ check_symbol_exists(CryptAcquireContext "windows.h;wincrypt.h" USE_WINCRYPT)
endif()
if(USE_WINCRYPT)
set(USE_WIN32_CRYPTO ON)