summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2022-12-26 10:25:23 +0100
committerDaniel Stenberg <daniel@haxx.se>2022-12-27 10:52:34 +0100
commitdfbe035c8b39b056a234bc76df3f384f7a7a24af (patch)
treefd0c45bdaea5daa88836c4be2af4e59431845f21 /CMakeLists.txt
parent728400f875e845f72ee5602edb905f6301ade3e7 (diff)
downloadcurl-dfbe035c8b39b056a234bc76df3f384f7a7a24af.tar.gz
cmake: bump requirement to 3.7
Because this is the cmake version (released in November 2016) that introduced GREATER_EQUAL, which is used already. Reported-by: nick-telia on github Fixes #10128 Closes #10161
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2bed81eae..982cf6729 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -60,7 +60,7 @@
# to ON or OFF), the symbol detection will be skipped. If the
# variable is NOT DEFINED, the symbol detection will be performed.
-cmake_minimum_required(VERSION 3.2...3.16 FATAL_ERROR)
+cmake_minimum_required(VERSION 3.7...3.16 FATAL_ERROR)
set(CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}/CMake;${CMAKE_MODULE_PATH}")
include(Utilities)