summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorXiang Xiao <xiaoxiang@xiaomi.com>2022-10-10 06:54:59 +0800
committerDaniel Stenberg <daniel@haxx.se>2022-10-10 23:23:22 +0200
commitd91c736f6c832d61c61cf407213c3c6f3b58d767 (patch)
treeb956078e86d411878835799a525ab22d2b2cef6b /CMakeLists.txt
parentd24a2ffefe37501e65b57719ca8a8aaa0035a57d (diff)
downloadcurl-d91c736f6c832d61c61cf407213c3c6f3b58d767.tar.gz
cmake: add the check of HAVE_SOCKETPAIR
which is used by Curl_socketpair Signed-off-by: Xiang Xiao <xiaoxiang@xiaomi.com> Closes #9686
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4cb983750..d3b4fc756 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1014,6 +1014,7 @@ endif()
check_symbol_exists(fchmod "${CURL_INCLUDES}" HAVE_FCHMOD)
check_symbol_exists(basename "${CURL_INCLUDES}" HAVE_BASENAME)
check_symbol_exists(socket "${CURL_INCLUDES}" HAVE_SOCKET)
+check_symbol_exists(socketpair "${CURL_INCLUDES}" HAVE_SOCKETPAIR)
check_symbol_exists(recv "${CURL_INCLUDES}" HAVE_RECV)
check_symbol_exists(send "${CURL_INCLUDES}" HAVE_SEND)
check_symbol_exists(select "${CURL_INCLUDES}" HAVE_SELECT)