summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJay Satiro <raysatiro@yahoo.com>2023-02-17 03:40:05 -0500
committerJay Satiro <raysatiro@yahoo.com>2023-02-18 19:02:37 -0500
commitcab040248d3fba3600825d77d56383019066b447 (patch)
treef48ac4fcafe38d6f0bc9b77f4258ef2ac964c1e4 /CMakeLists.txt
parent65d751d4cccb3d43e9397c4ca0b585450495b28f (diff)
downloadcurl-cab040248d3fba3600825d77d56383019066b447.tar.gz
curl_setup: Suppress OpenSSL 3 deprecation warnings
- Define OPENSSL_SUPPRESS_DEPRECATED. OpenSSL 3 has deprecated some of the functions libcurl uses such as those with DES, MD5 and ENGINE prefix. We don't have replacements for those functions so the warnings were disabled in autotools and cmake builds, but still showed in other builds. Closes https://github.com/curl/curl/pull/10543
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 0 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index eb998fb0f..b97704bfe 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -448,8 +448,6 @@ if(CURL_USE_OPENSSL)
if(NOT DEFINED HAVE_BORINGSSL)
check_symbol_exists(OPENSSL_IS_BORINGSSL "openssl/base.h" HAVE_BORINGSSL)
endif()
-
- add_definitions(-DOPENSSL_SUPPRESS_DEPRECATED)
endif()
if(CURL_USE_MBEDTLS)