summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorViktor Szakats <commit@vsz.me>2023-01-25 11:55:57 +0000
committerViktor Szakats <commit@vsz.me>2023-01-25 11:55:57 +0000
commitc0958b7ea1eb9c5d5c83bc3f20b4a17e568a4458 (patch)
treeeacaac0fb18e2eab83d2dec65cc53fe06bb5263a /CMakeLists.txt
parent3f11122b2faee2fb3bd0067b3526a7900929ba7d (diff)
downloadcurl-c0958b7ea1eb9c5d5c83bc3f20b4a17e568a4458.tar.gz
cmake: delete redundant macro definition `SECURITY_WIN32`
Stop explicitly defining `SECURITY_WIN32` in CMake builds. No other build systems define this macro, because it's unconditionally defined in `lib/curl_sspi.h` already. This is the only curl source using the `sspi.h` and `security.h` Win32 headers, and no other Win32 headers need this macro. Reviewed-by: Jay Satiro Closes #10341
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ffb362f9b..cf40054f9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -402,7 +402,6 @@ if(CURL_USE_SCHANNEL)
endif()
if(CURL_WINDOWS_SSPI)
set(USE_WINDOWS_SSPI ON)
- list(APPEND CMAKE_REQUIRED_DEFINITIONS -DSECURITY_WIN32)
endif()
if(CURL_USE_SECTRANSP)