summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorViktor Szakats <commit@vsz.me>2022-10-26 09:43:50 +0000
committerViktor Szakats <commit@vsz.me>2022-10-26 09:45:23 +0000
commitb51560b9ffc9494dc04b2cad927cb69ab9087d48 (patch)
tree4be59d41e95e977e78f743c25bf9055c505bf207 /CMakeLists.txt
parent279834dd45008a44a3028e20f82f8a9f4401a40d (diff)
downloadcurl-b51560b9ffc9494dc04b2cad927cb69ab9087d48.tar.gz
winidn: drop WANT_IDN_PROTOTYPES
`WANT_IDN_PROTOTYPES` was necessary to avoid using a header that came via an optional package. MS stopped distributing this package some years ago and the winidn definitions are part of standard headers (via `windows.h`) since Vista. Auto-detect Vista inside `lib/idn_win32.c` and enable the manual definitions if building for an older Windows. This allows to delete this manual knob from all build-systems. Also drop the `_SAL_VERSION` sub-case: Our manual definitions are now only enabled with old systems. We assume that code analysis is not run on such systems, allowing us to delete the SAL-friendly flavour of these. Reviewed-by: Jay Satiro Closes #9793
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 62fee8e6d..03b422dc5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -704,7 +704,6 @@ if(WIN32)
option(USE_WIN32_IDN "Use WinIDN for IDN support" OFF)
if(USE_WIN32_IDN)
list(APPEND CURL_LIBS "normaliz")
- set(WANT_IDN_PROTOTYPES ON)
endif()
endif()