summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorxgladius <xgladius@xgladiuss-iMac-Pro.local>2023-01-17 12:08:10 -0600
committerJay Satiro <raysatiro@yahoo.com>2023-01-20 17:11:04 -0500
commitac6e7f5689c35cf22b9ebc9ecec48524d5c2f587 (patch)
tree080292375be2fb64244c0839a2d8a213057d5266 /CMakeLists.txt
parent5a70403cff2bfc01621abfa6ee432aa84542eb4c (diff)
downloadcurl-ac6e7f5689c35cf22b9ebc9ecec48524d5c2f587.tar.gz
cmake: Remove deprecated symbols check
curl stopped use of CMAKE_USE_ as a prefix for its own build symbols in 2021 and added a check, meant to last 1 year, to fatally error on those symbols. This commit removes that check. Closes https://github.com/curl/curl/pull/10314
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt18
1 files changed, 0 insertions, 18 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 177efb6ce..a038ad0ae 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -358,24 +358,6 @@ if(WIN32)
check_library_exists_concat("winmm" getch HAVE_LIBWINMM)
endif()
-# This check below for use of deprecated symbols is only temporary and is to
-# be removed again after a year's service. Remove after November 25, 2022.
-set(CURL_RECONFIG_REQUIRED 0)
-foreach(_LIB GSSAPI OPENLDAP LIBSSH LIBSSH2 BEARSSL MBEDTLS NSS OPENSSL
- SCHANNEL SECTRANSP WOLFSSL)
- if(CMAKE_USE_${_LIB})
- set(CURL_RECONFIG_REQUIRED 1)
- message(SEND_ERROR "The option CMAKE_USE_${_LIB} was renamed to CURL_USE_${_LIB}.")
- endif()
-endforeach()
-if(CMAKE_USE_WINSSL)
- set(CURL_RECONFIG_REQUIRED 1)
- message(SEND_ERROR "The option CMAKE_USE_WINSSL was renamed to CURL_USE_SCHANNEL.")
-endif()
-if(CURL_RECONFIG_REQUIRED)
- message(FATAL_ERROR "Reconfig required")
-endif()
-
# check SSL libraries
# TODO support GnuTLS
option(CURL_ENABLE_SSL "Enable SSL support" ON)