summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorViktor Szakats <commit@vsz.me>2022-10-14 19:06:37 +0000
committerViktor Szakats <commit@vsz.me>2022-10-14 19:07:16 +0000
commit86f2d8f67f0e4255128e448e531d91aec4cfd6be (patch)
tree09fc9117c44ca25ec6bed3c79266ff89071c9be8 /CMakeLists.txt
parent67d88626d44ec04b9e11dca4cfbf62cd29fe9781 (diff)
downloadcurl-86f2d8f67f0e4255128e448e531d91aec4cfd6be.tar.gz
cmake: set HAVE_SOCKADDR_IN6_SIN6_SCOPE_ID on Windows
`lib/config-win32.h` enables this configuration option unconditionally. Make it apply to CMake builds as well. While here, delete a broken check for `HAVE_SOCKADDR_IN6_SIN6_SCOPE_ID` from `CMakeLists.txt`. This came with the initial commit [1], but did not include the actual verification code inside `CMake/CurlTests.c`, so it always failed. A later commit [2] added a second test, for non-Windows platforms. Enabling this flag causes test 1056 to fail with CMake builds, as they do with autotools builds. Let's apply the same solution and ignore the results here as well. [1] 4c5307b45655ba75ab066564afdc0c111a8b9291 [2] aec7c5a87c8482b6ddffa352d7d220698652262e Reviewed-by: Daniel Stenberg Assisted-by: Marcel Raad Closes #9726
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0ee96db6b..a9587be4a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1117,7 +1117,6 @@ foreach(CURL_TEST
HAVE_IOCTL_FIONBIO
HAVE_IOCTL_SIOCGIFADDR
HAVE_SETSOCKOPT_SO_NONBLOCK
- HAVE_SOCKADDR_IN6_SIN6_SCOPE_ID
TIME_WITH_SYS_TIME
HAVE_O_NONBLOCK
HAVE_GETHOSTBYNAME_R_3