summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStefan Eissing <stefan@eissing.org>2022-11-25 14:06:43 +0100
committerDaniel Stenberg <daniel@haxx.se>2022-11-28 13:56:23 +0100
commit55807e6c056f27846d70cec70ee6ac3f0e5b3bbe (patch)
tree85ab09a67ed74d35a1c6689ed539bac116f08341 /CMakeLists.txt
parentdbd74baf781e33e95071a729a81c91a972eff0b7 (diff)
downloadcurl-55807e6c056f27846d70cec70ee6ac3f0e5b3bbe.tar.gz
tls: backends use connection filters for IO, enabling HTTPS-proxy
- OpenSSL (and compatible) - BearSSL - gnutls - mbedtls - rustls - schannel - secure-transport - wolfSSL (v5.0.0 and newer) This leaves only the following without HTTPS-proxy support: - gskit - nss - wolfSSL (versions earlier than v5.0.0) Closes #9962
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 13aff5f4b..ce03d4bda 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1463,7 +1463,10 @@ _add_if("TLS-SRP" USE_TLS_SRP)
_add_if("HTTP2" USE_NGHTTP2)
_add_if("HTTP3" USE_NGTCP2 OR USE_QUICHE)
_add_if("MultiSSL" CURL_WITH_MULTI_SSL)
-_add_if("HTTPS-proxy" SSL_ENABLED AND (USE_OPENSSL OR USE_GNUTLS OR USE_NSS))
+# TODO wolfSSL only support this from v5.0.0 onwards
+_add_if("HTTPS-proxy" SSL_ENABLED AND (USE_OPENSSL OR USE_GNUTLS OR USE_NSS
+ OR USE_SCHANNEL OR USE_RUSTLS OR USE_BEARSSL OR
+ USE_MBEDTLS OR USE_SECTRANSP))
_add_if("unicode" ENABLE_UNICODE)
_add_if("threadsafe" HAVE_ATOMIC OR (WIN32 AND
HAVE_WIN32_WINNT GREATER_EQUAL 0x600))