summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorViktor Szakats <commit@vsz.me>2022-10-14 17:31:19 +0000
committerViktor Szakats <commit@vsz.me>2022-10-14 17:31:19 +0000
commit1d64a2bf5b46f0639cc07e674bf502cbd16c391d (patch)
treedfc3f05cbf38b1eee5b29cebb3e595b3e9c56b76 /CMakeLists.txt
parent8c452b4003d352c9f90d2116bdeed3d5bfbc8356 (diff)
downloadcurl-1d64a2bf5b46f0639cc07e674bf502cbd16c391d.tar.gz
cmake: delete duplicate HAVE_GETADDRINFO test
A custom `HAVE_GETADDRINFO` check came with the initial CMake commit [1]. A later commit [2] added a standard check for it as well. The standard check run before the custom one, so CMake ignored the latter. The custom check was also non-portable, so this patch deletes it in favor of the standard check. [1] 4c5307b45655ba75ab066564afdc0c111a8b9291 [2] aec7c5a87c8482b6ddffa352d7d220698652262e Closes #9731
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 156fe7903..70ef457cf 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1130,7 +1130,6 @@ foreach(CURL_TEST
HAVE_IN_ADDR_T
HAVE_BOOL_T
STDC_HEADERS
- HAVE_GETADDRINFO
HAVE_FILE_OFFSET_BITS
HAVE_VARIADIC_MACROS_C99
HAVE_VARIADIC_MACROS_GCC