summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py7
1 files changed, 7 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index fff43619ae..39aff67ab3 100644
--- a/setup.py
+++ b/setup.py
@@ -1279,6 +1279,13 @@ class PyBuildExt(build_ext):
else:
missing.append('_bz2')
+ # LZMA compression support.
+ if self.compiler.find_library_file(lib_dirs, 'lzma'):
+ exts.append( Extension('_lzma', ['_lzmamodule.c'],
+ libraries = ['lzma']) )
+ else:
+ missing.append('_lzma')
+
# Interface to the Expat XML parser
#
# Expat was written by James Clark and is now maintained by a group of