summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorRonald Oussoren <ronaldoussoren@mac.com>2010-10-20 13:11:46 +0000
committerRonald Oussoren <ronaldoussoren@mac.com>2010-10-20 13:11:46 +0000
commit6e29bc7d995e862b65646405a6c84a4885e3ed51 (patch)
tree68bfc8223c56785c247672962b150ddf8c2dc671 /setup.py
parent4f4ad6fe9de930e927e0b2dc18af82b53ab02497 (diff)
downloadcpython-6e29bc7d995e862b65646405a6c84a4885e3ed51.tar.gz
Merged revisions 85744 via svnmerge from
svn+ssh://pythondev@svn.python.org/python/branches/py3k ........ r85744 | ronald.oussoren | 2010-10-20 15:10:12 +0200 (Wed, 20 Oct 2010) | 7 lines Fix for issue #7473. Without this patch you'll get link errors in some extensions (in particular the _curses_panel) one when you try to build a 3-way universal framework when you previously installed a 2-way universal framework using the python.org installer. ........
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py7
1 files changed, 6 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 4f895595ce..cc5358fff7 100644
--- a/setup.py
+++ b/setup.py
@@ -384,7 +384,12 @@ class PyBuildExt(build_ext):
for directory in reversed(options.dirs):
add_dir_to_list(dir_list, directory)
- if os.path.normpath(sys.prefix) != '/usr':
+ if os.path.normpath(sys.prefix) != '/usr' \
+ and not sysconfig.get_config_var('PYTHONFRAMEWORK'):
+ # OSX note: Don't add LIBDIR and INCLUDEDIR to building a framework
+ # (PYTHONFRAMEWORK is set) to avoid # linking problems when
+ # building a framework with different architectures than
+ # the one that is currently installed (issue #7473)
add_dir_to_list(self.compiler.library_dirs,
sysconfig.get_config_var("LIBDIR"))
add_dir_to_list(self.compiler.include_dirs,