summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorBenjamin Peterson <benjamin@python.org>2009-12-30 02:58:50 +0000
committerBenjamin Peterson <benjamin@python.org>2009-12-30 02:58:50 +0000
commit33aa9bcc0274dacb7492d45dbe1871534f0f7ee9 (patch)
tree4e77660bb5cca63b5cd8b167e3ce9706ab324cd2 /setup.py
parent268e8a062d2332ab18691fe7c119a8212514b158 (diff)
downloadcpython-33aa9bcc0274dacb7492d45dbe1871534f0f7ee9.tar.gz
only build the nis module when the headers are found #7589
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index f25b8294ea..d2334e7e57 100644
--- a/setup.py
+++ b/setup.py
@@ -1088,7 +1088,7 @@ class PyBuildExt(build_ext):
missing.append('resource')
# Sun yellow pages. Some systems have the functions in libc.
- if platform not in ['cygwin', 'atheos', 'qnx6']:
+ if platform not in ['cygwin', 'atheos', 'qnx6'] and find_file('rpcsvc/yp_prot.h', inc_dirs, []) is not None:
if (self.compiler_obj.find_library_file(lib_dirs, 'nsl')):
libs = ['nsl']
else: