summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py9
1 files changed, 0 insertions, 9 deletions
diff --git a/setup.py b/setup.py
index 11c4ec67f4..51e5d7eff7 100644
--- a/setup.py
+++ b/setup.py
@@ -922,19 +922,10 @@ class PyBuildExt(build_ext):
'Modules/_blake2/impl/*'))
blake2_deps.append('hashlib.h')
- blake2_macros = []
- if (not cross_compiling and
- os.uname().machine == "x86_64" and
- sys.maxsize > 2**32):
- # Every x86_64 machine has at least SSE2. Check for sys.maxsize
- # in case that kernel is 64-bit but userspace is 32-bit.
- blake2_macros.append(('BLAKE2_USE_SSE', '1'))
-
exts.append( Extension('_blake2',
['_blake2/blake2module.c',
'_blake2/blake2b_impl.c',
'_blake2/blake2s_impl.c'],
- define_macros=blake2_macros,
depends=blake2_deps) )
sha3_deps = glob(os.path.join(os.getcwd(), srcdir,