summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 0 insertions, 20 deletions
diff --git a/configure.ac b/configure.ac
index a02597da2d..e673e136be 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1543,26 +1543,6 @@ then
esac
fi
-if test -n "${cc_is_clang}"
-then
- # bpo-36618: Add -fmax-type-align=8 to CFLAGS when clang compiler is
- # detected. The pymalloc memory allocator aligns memory on 8 bytes. On
- # x86-64, clang expects alignment on 16 bytes by default and so uses MOVAPS
- # instruction which can lead to segmentation fault. Instruct clang that
- # Python is limited to alignemnt on 8 bytes to use MOVUPS instruction
- # instead: slower but don't trigger a SIGSEGV if the memory is not aligned
- # on 16 bytes.
- #
- # Sadly, the flag must be added to CFLAGS and not just CFLAGS_NODIST,
- # since third party C extensions can have the same issue.
- #
- # Check if -fmax-type-align flag is supported (it's not supported by old
- # clang versions):
- if "$CC" -v --help 2>/dev/null |grep -- -fmax-type-align > /dev/null; then
- CFLAGS="$CFLAGS -fmax-type-align=8"
- fi
-fi
-
AC_SUBST(BASECFLAGS)
AC_SUBST(CFLAGS_NODIST)
AC_SUBST(LDFLAGS_NODIST)