summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 2 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index f0bc8c6258..6ffe90a4c4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3622,12 +3622,6 @@ AC_MSG_CHECKING(DYNLOADFILE)
if test -z "$DYNLOADFILE"
then
case $ac_sys_system/$ac_sys_release in
- AIX*) # Use dynload_shlib.c and dlopen() if we have it; otherwise dynload_aix.c
- if test "$ac_cv_func_dlopen" = yes
- then DYNLOADFILE="dynload_shlib.o"
- else DYNLOADFILE="dynload_aix.o"
- fi
- ;;
hp*|HP*) DYNLOADFILE="dynload_hpux.o";;
*)
# use dynload_shlib.c and dlopen() if we have it; otherwise stub
@@ -3664,8 +3658,8 @@ fi
# checks for library functions
AC_CHECK_FUNCS(alarm accept4 setitimer getitimer bind_textdomain_codeset chown \
- clock confstr copy_file_range ctermid dup3 execv explicit_bzero explicit_memset \
- faccessat fchmod fchmodat fchown fchownat \
+ clock confstr close_range copy_file_range ctermid dup3 execv explicit_bzero \
+ explicit_memset faccessat fchmod fchmodat fchown fchownat \
fdwalk fexecve fdopendir fork fpathconf fstatat ftime ftruncate futimesat \
futimens futimes gai_strerror getentropy \
getgrgid_r getgrnam_r \