summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorINADA Naoki <songofacandy@gmail.com>2016-10-15 15:41:05 +0900
committerINADA Naoki <songofacandy@gmail.com>2016-10-15 15:41:05 +0900
commitfa8b8847e20e092cd6fb1610a88a7db1c48406ce (patch)
tree249abac5ec8b43495b7ab8969e7694a800c19c10 /setup.py
parent20e086efc7db911f7088440b17e52881cf53edda (diff)
parent9f2ce2548107eedaf0970546a508c33d24920622 (diff)
downloadcpython-git-fa8b8847e20e092cd6fb1610a88a7db1c48406ce.tar.gz
Issue #28428: Rename _futures module to _asyncio. (merge from 3.6)
It will have more speedup functions or classes other than asyncio.Future.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index b49d0675b0..68010b33db 100644
--- a/setup.py
+++ b/setup.py
@@ -657,8 +657,8 @@ class PyBuildExt(build_ext):
depends=['unicodedata_db.h', 'unicodename_db.h']) )
# _opcode module
exts.append( Extension('_opcode', ['_opcode.c']) )
- # Fast asyncio Future implementation
- exts.append( Extension("_futures", ["_futuresmodule.c"]) )
+ # asyncio speedups
+ exts.append( Extension("_asyncio", ["_asynciomodule.c"]) )
# Modules with some UNIX dependencies -- on by default:
# (If you have a really backward UNIX, select and socket may not be