summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorRonald Oussoren <ronaldoussoren@mac.com>2010-10-20 13:10:12 +0000
committerRonald Oussoren <ronaldoussoren@mac.com>2010-10-20 13:10:12 +0000
commitf3500e119865b28c34ffacb9f582db49b9d70e9d (patch)
tree1c2fd75133dd44b40b135da9e67dea33ed7b377a /setup.py
parentd0103292f052d3d5735d5b2d0a2307b02b75b8c3 (diff)
downloadcpython-git-f3500e119865b28c34ffacb9f582db49b9d70e9d.tar.gz
Fix for issue #7473.
Without this patch you'll get link errors in some extensions (in particular the _curses_panel) one when you try to build a 3-way universal framework when you previously installed a 2-way universal framework using the python.org installer.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py7
1 files changed, 6 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 549eccbb45..3cdcea17b8 100644
--- a/setup.py
+++ b/setup.py
@@ -400,7 +400,12 @@ class PyBuildExt(build_ext):
for directory in reversed(options.dirs):
add_dir_to_list(dir_list, directory)
- if os.path.normpath(sys.prefix) != '/usr':
+ if os.path.normpath(sys.prefix) != '/usr' \
+ and not sysconfig.get_config_var('PYTHONFRAMEWORK'):
+ # OSX note: Don't add LIBDIR and INCLUDEDIR to building a framework
+ # (PYTHONFRAMEWORK is set) to avoid # linking problems when
+ # building a framework with different architectures than
+ # the one that is currently installed (issue #7473)
add_dir_to_list(self.compiler.library_dirs,
sysconfig.get_config_var("LIBDIR"))
add_dir_to_list(self.compiler.include_dirs,