summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorXavier de Gaye <xdegaye@users.sourceforge.net>2016-12-14 11:16:06 +0100
committerXavier de Gaye <xdegaye@users.sourceforge.net>2016-12-14 11:16:06 +0100
commite43edaad7e2ba2132662267745c73754fc3b2d77 (patch)
tree11979df8e573eb396190cc177959e27b92dd2754 /setup.py
parentf2392133eba777f05947a8996c507690b95379c3 (diff)
parent1351c31aa9651b278d7ef8ec79af3b646a520235 (diff)
downloadcpython-git-e43edaad7e2ba2132662267745c73754fc3b2d77.tar.gz
Issue #20211: Merge 3.6.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py5
1 files changed, 3 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index cd05bb6b90..2cbe9a5805 100644
--- a/setup.py
+++ b/setup.py
@@ -533,8 +533,9 @@ class PyBuildExt(build_ext):
for directory in reversed(options.dirs):
add_dir_to_list(dir_list, directory)
- if os.path.normpath(sys.base_prefix) != '/usr' \
- and not sysconfig.get_config_var('PYTHONFRAMEWORK'):
+ if (not cross_compiling and
+ os.path.normpath(sys.base_prefix) != '/usr' and
+ not sysconfig.get_config_var('PYTHONFRAMEWORK')):
# OSX note: Don't add LIBDIR and INCLUDEDIR to building a framework
# (PYTHONFRAMEWORK is set) to avoid # linking problems when
# building a framework with different architectures than