summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorINADA Naoki <songofacandy@gmail.com>2016-10-09 14:51:36 +0900
committerINADA Naoki <songofacandy@gmail.com>2016-10-09 14:51:36 +0900
commitca2f0d06f104b6d25ed1475aecde9d10451e488f (patch)
tree16ea99ad7a86ab85dd6ca8dadd04e4bbfb0610b0 /setup.py
parenta774a6bd8244a7ac97aa258939490b858264efb8 (diff)
parent9e4e38ecd2cb46e0e52d1b23de3dd95dcdf645bf (diff)
downloadcpython-git-ca2f0d06f104b6d25ed1475aecde9d10451e488f.tar.gz
Issue #26801: Added C implementation of asyncio.Future.
Original patch by Yury Selivanov.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 2 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 13fc8d63db..b49d0675b0 100644
--- a/setup.py
+++ b/setup.py
@@ -657,6 +657,8 @@ class PyBuildExt(build_ext):
depends=['unicodedata_db.h', 'unicodename_db.h']) )
# _opcode module
exts.append( Extension('_opcode', ['_opcode.c']) )
+ # Fast asyncio Future implementation
+ exts.append( Extension("_futures", ["_futuresmodule.c"]) )
# Modules with some UNIX dependencies -- on by default:
# (If you have a really backward UNIX, select and socket may not be