summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorDevin Jeanpierre <jeanpierreda@gmail.com>2017-09-06 11:15:35 -0700
committerGregory P. Smith <greg@krypto.org>2017-09-06 11:15:35 -0700
commitc5bace2bf7874cf47ef56e1d8d19f79ad892eef5 (patch)
tree30154359cfc75d55b8164619bcfaaaa65d2378ec /setup.py
parent5fcd5e64eec9ed67613b8fe7356fb8288151ceba (diff)
downloadcpython-git-c5bace2bf7874cf47ef56e1d8d19f79ad892eef5.tar.gz
bpo-29505: Add fuzz tests for float(str), int(str), unicode(str) (#2878)
Add basic fuzz tests for a few common builtin functions. This is an easy place to start, and these functions are probably safe. We'll want to add more fuzz tests later. Lets bootstrap using these. While the fuzz tests are included in CPython and compiled / tested on a very basic level inside CPython itself, the actual fuzzing happens as part of oss-fuzz (https://github.com/google/oss-fuzz). The reason to include the tests in CPython is to make sure that they're maintained as part of the CPython project, especially when (as some eventually will) they use internal implementation details in the test. (This will be necessary sometimes because e.g. the fuzz test should never enter Python's interpreter loop, whereas some APIs only expose themselves publicly as Python functions.) This particular set of changes is part of testing Python's builtins, tracked internally at Google by b/37562550. The _xxtestfuzz module that this change adds need not be shipped with binary distributions of Python.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 6 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 36a52bc6aa..3c7c9049ed 100644
--- a/setup.py
+++ b/setup.py
@@ -715,6 +715,12 @@ class PyBuildExt(build_ext):
# syslog daemon interface
exts.append( Extension('syslog', ['syslogmodule.c']) )
+ # Fuzz tests.
+ exts.append( Extension(
+ '_xxtestfuzz',
+ ['_xxtestfuzz/_xxtestfuzz.c', '_xxtestfuzz/fuzzer.c'])
+ )
+
#
# Here ends the simple stuff. From here on, modules need certain
# libraries, are platform-specific, or present other surprises.