summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorNed Deily <nad@acm.org>2013-08-01 23:53:24 -0700
committerNed Deily <nad@acm.org>2013-08-01 23:53:24 -0700
commitb467d1542a5d0e852a8a12e48e88c15f0c03bd98 (patch)
tree3c43227eb69d043ff75fcfa955bdf59d64ce6271 /setup.py
parent970a87fc07c780689c71764ad10de75bbac6d4d8 (diff)
parentcd3d8fb8259cead872c5b313918c9a545ae97279 (diff)
downloadcpython-git-b467d1542a5d0e852a8a12e48e88c15f0c03bd98.tar.gz
Issue #18517: merge from 3.3
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py17
1 files changed, 9 insertions, 8 deletions
diff --git a/setup.py b/setup.py
index dcaa804d80..d470e8fe40 100644
--- a/setup.py
+++ b/setup.py
@@ -1534,6 +1534,15 @@ class PyBuildExt(build_ext):
if '_tkinter' not in [e.name for e in self.extensions]:
missing.append('_tkinter')
+## # Uncomment these lines if you want to play with xxmodule.c
+## ext = Extension('xx', ['xxmodule.c'])
+## self.extensions.append(ext)
+
+ if 'd' not in sys.abiflags:
+ ext = Extension('xxlimited', ['xxlimited.c'],
+ define_macros=[('Py_LIMITED_API', 1)])
+ self.extensions.append(ext)
+
return missing
def detect_tkinter_darwin(self, inc_dirs, lib_dirs):
@@ -1731,14 +1740,6 @@ class PyBuildExt(build_ext):
)
self.extensions.append(ext)
-## # Uncomment these lines if you want to play with xxmodule.c
-## ext = Extension('xx', ['xxmodule.c'])
-## self.extensions.append(ext)
- if 'd' not in sys.abiflags:
- ext = Extension('xxlimited', ['xxlimited.c'],
- define_macros=[('Py_LIMITED_API', 1)])
- self.extensions.append(ext)
-
# XXX handle these, but how to detect?
# *** Uncomment and edit for PIL (TkImaging) extension only:
# -DWITH_PIL -I../Extensions/Imaging/libImaging tkImaging.c \