summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorChristian Heimes <christian@python.org>2016-09-18 14:35:39 +0200
committerChristian Heimes <christian@python.org>2016-09-18 14:35:39 +0200
commitaa630e051b0bada78b30d0eba7842931235b7b5e (patch)
tree04cc4d32aada2e3dedf6bbe4312f8db62a3251d8 /setup.py
parent892cc1952454341fe40da085befe0cb3dddb8d98 (diff)
parent85c98bf9682a46f7b15e9c79c68d38af8a9109b0 (diff)
downloadcpython-git-aa630e051b0bada78b30d0eba7842931235b7b5e.tar.gz
Issue #26661: setup.py now detects system libffi with multiarch wrapper.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py16
1 files changed, 9 insertions, 7 deletions
diff --git a/setup.py b/setup.py
index 607f0b1a6c..13fc8d63db 100644
--- a/setup.py
+++ b/setup.py
@@ -1976,14 +1976,16 @@ class PyBuildExt(build_ext):
ffi_inc = find_file('ffi.h', [], inc_dirs)
if ffi_inc is not None:
ffi_h = ffi_inc[0] + '/ffi.h'
- with open(ffi_h) as fp:
- while 1:
- line = fp.readline()
- if not line:
- ffi_inc = None
- break
- if line.startswith('#define LIBFFI_H'):
+ with open(ffi_h) as f:
+ for line in f:
+ line = line.strip()
+ if line.startswith(('#define LIBFFI_H',
+ '#define ffi_wrapper_h')):
break
+ else:
+ ffi_inc = None
+ print('Header file {} does not define LIBFFI_H or '
+ 'ffi_wrapper_h'.format(ffi_h))
ffi_lib = None
if ffi_inc is not None:
for lib_name in ('ffi', 'ffi_pic'):