summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorINADA Naoki <songofacandy@gmail.com>2016-10-15 15:39:19 +0900
committerINADA Naoki <songofacandy@gmail.com>2016-10-15 15:39:19 +0900
commit9f2ce2548107eedaf0970546a508c33d24920622 (patch)
tree2a410ccb15a3acb857985a3ce15e71fc7bdc3cda /setup.py
parent479eb760f4dd5ae5cfc5ccf8a361cdea3d48624a (diff)
downloadcpython-git-9f2ce2548107eedaf0970546a508c33d24920622.tar.gz
Issue #28428: Rename _futures module to _asyncio.
It will have more speedup functions or classes other than asyncio.Future.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 1d4a7f883a..b54ef81699 100644
--- a/setup.py
+++ b/setup.py
@@ -656,8 +656,8 @@ class PyBuildExt(build_ext):
depends=['unicodedata_db.h', 'unicodename_db.h']) )
# _opcode module
exts.append( Extension('_opcode', ['_opcode.c']) )
- # Fast asyncio Future implementation
- exts.append( Extension("_futures", ["_futuresmodule.c"]) )
+ # asyncio speedups
+ exts.append( Extension("_asyncio", ["_asynciomodule.c"]) )
# Modules with some UNIX dependencies -- on by default:
# (If you have a really backward UNIX, select and socket may not be