summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorINADA Naoki <songofacandy@gmail.com>2016-10-09 14:44:47 +0900
committerINADA Naoki <songofacandy@gmail.com>2016-10-09 14:44:47 +0900
commit9e4e38ecd2cb46e0e52d1b23de3dd95dcdf645bf (patch)
treee32422607ffd7841407b6fad1179cb3bda5118af /setup.py
parent518599b24ce015910a364152692d60733c40f88f (diff)
downloadcpython-git-9e4e38ecd2cb46e0e52d1b23de3dd95dcdf645bf.tar.gz
Issue #26801: Added C implementation of asyncio.Future.
Original patch by Yury Selivanov.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 2 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index a1989aa3cc..1d4a7f883a 100644
--- a/setup.py
+++ b/setup.py
@@ -656,6 +656,8 @@ class PyBuildExt(build_ext):
depends=['unicodedata_db.h', 'unicodename_db.h']) )
# _opcode module
exts.append( Extension('_opcode', ['_opcode.c']) )
+ # Fast asyncio Future implementation
+ exts.append( Extension("_futures", ["_futuresmodule.c"]) )
# Modules with some UNIX dependencies -- on by default:
# (If you have a really backward UNIX, select and socket may not be