summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMiss Islington (bot) <31488909+miss-islington@users.noreply.github.com>2019-04-26 09:15:31 -0700
committerGitHub <noreply@github.com>2019-04-26 09:15:31 -0700
commit967f14ec2aff908b7f9e84e93aa60f2a34e2ca96 (patch)
tree04c8e896fe6d2c0a638a186ab9f72f5287561869 /setup.py
parent1069d38fa18f3a4f97c2e358bcb3b82cab1c051b (diff)
downloadcpython-git-967f14ec2aff908b7f9e84e93aa60f2a34e2ca96.tar.gz
bpo-31525: Increase minimum sqlite version number check (GH-12923)
(cherry picked from commit ad0daf5b374dc43540d4ffcf32ca30e5c5147b90) Co-authored-by: Charles Pigott <charlespigott@googlemail.com>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 3 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index b4357e39cf..bcc4bfa89d 100644
--- a/setup.py
+++ b/setup.py
@@ -1130,7 +1130,7 @@ class PyBuildExt(build_ext):
sqlite_setup_debug = False # verbose debug prints from this script?
# We hunt for #define SQLITE_VERSION "n.n.n"
- # We need to find >= sqlite version 3.0.8
+ # We need to find >= sqlite version 3.3.9, for sqlite3_prepare_v2
sqlite_incdir = sqlite_libdir = None
sqlite_inc_paths = [ '/usr/include',
'/usr/include/sqlite',
@@ -1141,7 +1141,7 @@ class PyBuildExt(build_ext):
]
if cross_compiling:
sqlite_inc_paths = []
- MIN_SQLITE_VERSION_NUMBER = (3, 0, 8)
+ MIN_SQLITE_VERSION_NUMBER = (3, 3, 9)
MIN_SQLITE_VERSION = ".".join([str(x)
for x in MIN_SQLITE_VERSION_NUMBER])
@@ -1175,7 +1175,7 @@ class PyBuildExt(build_ext):
break
else:
if sqlite_setup_debug:
- print("%s: version %d is too old, need >= %s"%(d,
+ print("%s: version %s is too old, need >= %s"%(d,
sqlite_version, MIN_SQLITE_VERSION))
elif sqlite_setup_debug:
print("sqlite: %s had no SQLITE_VERSION"%(f,))