summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorChristian Heimes <christian@python.org>2016-09-18 14:34:13 +0200
committerChristian Heimes <christian@python.org>2016-09-18 14:34:13 +0200
commit85c98bf9682a46f7b15e9c79c68d38af8a9109b0 (patch)
tree8592062b314091dedff37a27c5218dbd41d51f4f /setup.py
parent44efa8aa0b525bb1f3a5325bc72a4d7e1289c0e0 (diff)
parent96b2dd5997735f417526758cbe3ab497850baf71 (diff)
downloadcpython-git-85c98bf9682a46f7b15e9c79c68d38af8a9109b0.tar.gz
Issue #26661: setup.py now detects system libffi with multiarch wrapper.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py16
1 files changed, 9 insertions, 7 deletions
diff --git a/setup.py b/setup.py
index b752a671c6..a1989aa3cc 100644
--- a/setup.py
+++ b/setup.py
@@ -2025,14 +2025,16 @@ class PyBuildExt(build_ext):
ffi_inc = find_file('ffi.h', [], inc_dirs)
if ffi_inc is not None:
ffi_h = ffi_inc[0] + '/ffi.h'
- with open(ffi_h) as fp:
- while 1:
- line = fp.readline()
- if not line:
- ffi_inc = None
- break
- if line.startswith('#define LIBFFI_H'):
+ with open(ffi_h) as f:
+ for line in f:
+ line = line.strip()
+ if line.startswith(('#define LIBFFI_H',
+ '#define ffi_wrapper_h')):
break
+ else:
+ ffi_inc = None
+ print('Header file {} does not define LIBFFI_H or '
+ 'ffi_wrapper_h'.format(ffi_h))
ffi_lib = None
if ffi_inc is not None:
for lib_name in ('ffi', 'ffi_pic'):