summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorEric Snow <ericsnowcurrently@gmail.com>2018-01-29 18:23:44 -0700
committerGitHub <noreply@github.com>2018-01-29 18:23:44 -0700
commit7f8bfc9b9a8381ddb768421b5dd5cbd970266190 (patch)
tree51b8fe00614bdc56c0c32ab2c61d921b225022a8 /setup.py
parent332cd5ee4ff42c9904c56e68a1028f383f7fc9a8 (diff)
downloadcpython-git-7f8bfc9b9a8381ddb768421b5dd5cbd970266190.tar.gz
bpo-32604: Expose the subinterpreters C-API in a "private" stdlib module. (gh-1748)
The module is primarily intended for internal use in the test suite. Building the module under Windows will come in a follow-up PR.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 4 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index ba0a7624cf..6f9a39719b 100644
--- a/setup.py
+++ b/setup.py
@@ -755,6 +755,10 @@ class PyBuildExt(build_ext):
['_xxtestfuzz/_xxtestfuzz.c', '_xxtestfuzz/fuzzer.c'])
)
+ # Python interface to subinterpreter C-API.
+ exts.append(Extension('_xxsubinterpreters', ['_xxsubinterpretersmodule.c'],
+ define_macros=[('Py_BUILD_CORE', '')]))
+
#
# Here ends the simple stuff. From here on, modules need certain
# libraries, are platform-specific, or present other surprises.