summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorStefan Krah <skrah@bytereef.org>2017-02-04 14:58:50 +0100
committerStefan Krah <skrah@bytereef.org>2017-02-04 14:58:50 +0100
commit75c0d4f6bb97e723adc3a03c0ff6aaaee0c6981a (patch)
treea8894ef23029ec8b66a09b918a4ecf0946d2dbfd /setup.py
parented4de13f0607c41d953269375d45af3f5f3979a4 (diff)
downloadcpython-git-75c0d4f6bb97e723adc3a03c0ff6aaaee0c6981a.tar.gz
Issue29439: _decimal on Android requires linking with libm.
Patch by Chi Hsuan Yen.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index d218722e0e..f04bf229f1 100644
--- a/setup.py
+++ b/setup.py
@@ -2064,7 +2064,7 @@ class PyBuildExt(build_ext):
'Modules',
'_decimal',
'libmpdec'))]
- libraries = []
+ libraries = self.detect_math_libs()
sources = [
'_decimal/_decimal.c',
'_decimal/libmpdec/basearith.c',