summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorStefan Krah <skrah@bytereef.org>2017-07-13 20:54:20 +0200
committerGitHub <noreply@github.com>2017-07-13 20:54:20 +0200
commit72b543308ee3087e3fa247981f5cb4be1138c515 (patch)
tree48cd325e3c4bcc84ccae4c3b463a6865472c5f28 /setup.py
parentd3aaa2f1496aae0809c9ec9623fa528d3a2c16c2 (diff)
downloadcpython-git-72b543308ee3087e3fa247981f5cb4be1138c515.tar.gz
bpo-30923: Suppress fall-through warnings in libmpdec. (#2698)
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 3 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 41aad8210d..4f0f522bf8 100644
--- a/setup.py
+++ b/setup.py
@@ -2119,6 +2119,9 @@ class PyBuildExt(build_ext):
else:
raise DistutilsError("_decimal: unsupported architecture")
+ if 'gcc' in cc: # Suppressing the warnings in the source is too verbose.
+ extra_compile_args.append('-Wno-implicit-fallthrough')
+
# Workarounds for toolchain bugs:
if sysconfig.get_config_var('HAVE_IPA_PURE_CONST_BUG'):
# Some versions of gcc miscompile inline asm: